Szükséges programverzió

témakör: Keretrendszer

A Symbol Ügyvitel folyamatos fejlesztése miatt szükség lehet arra, hogy a SyX beépülő készítője beállítsa, hogy milyen verziója Symbol Ügyvitel szükséges a futtatáshoz. A SyX Visual Studio-ban lefordítható például a v1.70-es SDK-val, de nem fog futni olyan Symbol Ügyvitellel, amely csak 1.64-es verziószámú.

Például, a Symbol Ügyvitel v1.66-es verziójától elérhető a Szerződéses árak telephelyhez való rendelése. Amennyiben a SyX beépülő ezt használja, meg kell adni a

[RequiredVersion(1, 66)]

attribútumot, hogy csak azok a felhasználók érhessék el, akik frissítettek v1.66-ra.

Hozzászólok